查看: 975|回复: 0
打印 上一主题 下一主题

Canfestival对象字典工具objdictedit运行环境配置

[复制链接]

45

主题

47

帖子

616

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
616
跳转到指定楼层
楼主
发表于 2019-5-16 16:43:51 | 只看该作者 |只看大图 回帖奖励 |倒序浏览 |阅读模式
CanFestival致力于提供一个独立于ANSI-C平台的CANOpen协议栈,它可以作为PC、实时IPCs和微控制器上的主节点或从节点实现。还提供了一个基于wxPython的图形化CanOpen对象字典编辑器objdictedit

CanFestival软件下载:

Canfestival对象字典生成工具是用Python写的,objdictedit.py文件就在CanFestival-3\objdictgen文件夹里面,要成功运行这个objdictgen.py,就必需得依次安装PythonwxPythonGnosis_Utils三个软件。


根据官方文档CanFestival-3\objdictgen\doc\manual_en.pdf要求,安装Python(至少2.4版,安装时注意添加环境变量,Python 3以上版本不支持)wxPython(至少2.6.3.2)


我的操作系统是Windows10-64位,安装过程中遇到了一些问题,来来回回折腾了好几次,最后安装成功,亲测可用的软件分别是:python-2.7.10.amd64wxPython2.8-win64-unicode-2.8.12.1-py27Gnosis_Utils-1.2.2

下面记录一下安装步骤:

步骤一
双击python-2.7.10.amd64.msi安装Python-2.7,一路默认安装下去就可以了,Win10默认安装在C:\Python27,也可以改变安装路径,注意路径不要带空格。
安装时记得选择Add python.exeto Path,也可以在安装完成之后手动将安装路径添加到系统环境变量中。


步骤二
双击wxPython2.8-win64-unicode-2.8.12.1-py27.exe安装wxPython2.8,一路默认安装下去就行了。
注意:wxPython要和Python的版本对应才行,版本不匹配导致安装失败或者安装成功后objdictedit部分功能不可用。

步骤三
解压Gnosis_Utils-1.2.2.zip,根据README文件的提示安装,在cmd或者powershell下进入此文件夹,运行pythonsetup.py install,多个版本的Python可以运行python setup.py install_all一次安装完毕。
Installation (*):
? ?pythonsetup.py install
? ?| Shortcut:(**)
? ?|? ?If you have multiple versions of Pythoninstalled, you can
? ?|? ?install for all of them at one time byusing:
? ?|
? ?|? ???python setup.py install_all



安装完毕,双击objdictedit.py,出现图形界面。恭喜你,大功告成!
下图是打开CanFestival-3\objdictgen\examples\example_objdict.od的效果。


软件下载
操作系统Win10-64bit,三种软件的版本和下载链接如下:
1. python-2.7.10.amd64.msi
2.wxPython2.8-win64-unicode-2.8.12.1-py27.exe
3. Gnosis_Utils-1.2.2.zip

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表